Descubierto un agujero de seguridad en los procesadores Exynos 4

COMPARTIR 0 TWITTEAR

Un fallo aparece al acecho de los distintos dispositivos de la gama de Samsung que hacen uso del procesador Exynos 4. El exploit hace que cualquier aplicación pueda obtener permisos de administrador y acceder a todos los datos de nuestro dispositivo. En el lado bueno, este fallo permite que podamos efectuar el root con un solo click desde el mismo dispositivo. ¿Cuanto tardará Samsung en sacar un parche a tal efecto?

El procesador afectado por el exploit

¿Eres un usuario que disfruta haciendo pruebas con tu terminal? ¿Tienes en tu poder un teléfono con un procesador Exynos 4? Puedes estar de enhorabuena, pero eso sí, entre comillas.

Y es que esta mañana el forero @alephzain en el conocido foro xda-developers ha hecho público un importante descubrimiento. Se ha descubierto un exploit en el Kernel de los procesadores Exynos 4 que puede hacer que un tercero acceda mediante una aplicación creada a tal efecto a todos los datos que almacenamos en nuestro móvil. Samsung ya está al tanto de este problema y se espera que pronto saquen un parche, algo a lo que se refieren en este hilo.

Esta es la parte mala. En el lado positivo encontramos que este agujero de seguridad puede facilitar la labor para efectuar el root a nuestro dispositivo. De hecho, el conocido desarrollador Chainfire ha sacado una aplicación que permite explotar este fallo para instalar SuperSu con un simple click desde nuestro dispositivo. Los productos afectados por este fallo aparecen enumerados en el siguiente listado:

  • Samsung Galaxy S2 GT-I9100.
  • Samsung Galaxy S3 GT-I9300.
  • Samsung Galaxy S3 LTE GT-I9305.
  • Samsung Galaxy Note GT-N7000.
  • Samsung Galaxy Note 2 GT-N7100.
  • Verizon Galaxy Note 2 SCH-I605.
  • Samsung Galaxy Note 10.1 GT-N8000.
  • Samsung Galaxy Note 10.1 GT-N8010.

Como veis aparecen todos los dispositivos que podemos observar en la lista constituyen la plana mayor de lo que podemos considerar la gama alta de la firma coreana, por lo que Samsung, viendo la gravedad es probable que no tarde en lanzar un parche que deberíamos recibir en forma de actualización vía OTA siempre y cuando tengamos uno de estos dispositivos.

Por otro lado, como citan en xdadevelopers codeworkx ya ha empezado a trabajar en el problema y el próximo Kernel de CyanogenMod 10.1 ya vendrá con este agujero de seguridad cubierto. Distintos usuarios manifiestan que el root es fácil de hacer y no aumenta ni el contador de flasheos ni cambia el estado del terminal. Además afirma que se puede devolver el dispositivo al estado original desde la propia aplicación SuperSu.

Actualización: Hay novedades al respecto, y es que sin necesidad de esperar a que Samsung haya sacado un parche al mercado, el usuario Supercurio ha lanzado una sencilla aplicación para parchear esta vulnerabilidad. Esta aplicación nos hace saber si nuestro dispositivo es vulnerable, cierra el exploit sin requerir acceso root y no modifica el estado de nuestro dispositivo. No obstante aún está en desarrollo y puede afectar en algunos casos tanto a la cámara como a la salida HDMI en algunos dispositivos.

Descarga | Parche Supercurio

¡Únete a nuestro canal de Telegram con lo más destacado del día y las mejores ofertas Android!

Únete a nuestro canal de Telegram
Archivado en Exploit, Root y ROMs Android, Samsung Exynos 4, Samsung Galaxy Note II, Samsung Galaxy S II, Samsung Galaxy S III
COMPARTIR 0 TWITTEAR

Comentarios (7)

Usa tu cuenta de Facebook para dejar tu opinión.

Publica tu opinión usando tu cuenta de Facebook.

¿Te ha gustado? ¡No te pierdas nada más!

follow us in feedly

Otras webs de Difoosion