Google habla sobre el agujero de seguridad en Android 4.3 Jelly Bean y anteriores

COMPARTIR 0 TWITTEAR

Código fuente de Android Jelly Bean ya disponible

Como recordaréis muchos de vosotros, hace unos días hablábamos de la vulnerabilidad real que existe en dispositivos con Android 4.3 Jely Bean e inferior. Estos dispositivos son más propicios a recibir ataques o infectarse con algún tipo de malware, debido a que Google ha decidido abandonar el soporte para WebView en esas versiones antiguas, por lo que ya no reciben los parches de seguridad necesarios.

Ahora, Google ha querido salir al paso para explicar los motivos que la han llevado a optar por esta opción. Tal y como leemos en el comunicado de Adrian Ludwig, se trata de una cuestión puramente práctica, y es que no ven factible el hecho de tener que actualizar la versión de WebKit que usa WebView en versiones inferiores a Android 4.4 KitKat.

Según el propio Ludwig, estamos hablando de más de 5 millones de líneas de código. Añadir parches de seguridad a versiones con más de dos años de antigüedad supondría modificar gran parte de este código, lo que a la larga no se podría hacer de forma práctica garantizando a su vez la seguridad requerida.

Ante esta problemática, lógicamente lo mejor sería actualizar cuanto antes a Android 4.4 KitKat, pero de no ser posible, por suerte hay formas de esquivar con garantías posibles infecciones. Primero, debemos tener en cuenta que este fallo de seguridad no lo sufren los navegadores con su propio motor de renderizado, como Chrome o Firefox, y es que solo se encuentra en aquellas apps que hacen uso de WebView para crear una especie de navegador propio al que accedemos para ver cierto contenido.

La solución entonces pasaría por evitar ese tipo de aplicaciones, o si la propia app nos lo permite, no elegir como navegador el que nos proporcionan, sino cualquiera de los mencionados, u otro entre los muchos que podemos encontrar en Google Play.

¡Síguenos en Telegram para enterarte de lo más destacado del día y de las mejores ofertas Android!

Archivado en Android 4.3 Jelly Bean, Android 4.4 KitKat, Navegadores Android, Seguridad Android, Webkit
COMPARTIR 0 TWITTEAR

Comentarios (5)

Usa tu cuenta de Facebook para dejar tu opinión.

Publica tu opinión usando tu cuenta de Facebook.

¿Te ha gustado? ¡No te pierdas nada más!

follow us in feedly

Nuestros blogs